DNA Sorting
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 80761 | Accepted: 32497 |
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
Sample Output
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
题意+思路:每行字符串找到有多少前面字母比后面字母大的数,然后按照这个数进行排序,一次输出所有字符串。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{ int a,b;
}DNA[110];
bool cmp(node a,node b)
{ if(a.b==b.b)
return a.a<b.a;
else
return a.b<b.b;
}
char s[210][210];
int main()
{ int n,m,i,j,k,z,p;
scanf("%d%d",&n,&m);
for(i=1;i<=m;i++)
{ scanf("%s",s[i]);
z=0;
for(j=0;j<n-1;j++)
for(k=j+1;k<n;k++)
{ p=s[i][j]-s[i][k];
if(p>0)
z++;
}
DNA[i].a=i;
DNA[i].b=z;
}
sort(DNA+1,DNA+1+m,cmp);
for(i=1;i<=m;i++)
printf("%s\n",s[DNA[i].a]);
}