java dna框架_杭电1379(DNA Sorting)java面向对象编程

Problem Description

One measure of ``unsortedness‘‘ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC‘‘, this measure is 5, since D is greater than four letters

to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG‘‘ has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM‘‘ has 6 inversions (it is

as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness‘‘, from ``most sorted‘‘ to ``least sorted‘‘.

All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string

of length n.

Output

Output the list of input strings, arranged from ``most sorted‘‘ to ``least sorted‘‘. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input

1

10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

面向对象编程,虽然看上去麻烦,但思路清晰。

import java.util.*;

class Main{

public static void main(String[] args){

int n,m,i,j,t;

String str;

Scanner sc=new Scanner(System.in);

t=sc.nextInt();

while(t-->0){

n=sc.nextInt();

m=sc.nextInt();

sc.nextLine();

StringSort[] strs=new StringSort[m];

for(i=0;i

str=sc.nextLine();

strs[i]=new StringSort(str);

}

for(i=0;i

strs[i].measure();

}

sort(strs);

for(i=0;i

System.out.println(strs[i].str);

}

}

}

public static void sort(StringSort[] strs){

for(int i=0;i

int minIndex=i;

for(int j=i+1;j

if(strs[j].count

minIndex=j;

}

}

if(minIndex!=i){

StringSort temp=strs[i];

strs[i]=strs[minIndex];

strs[minIndex]=temp;

}

}

}

}

class StringSort{

String str;

int count;

public StringSort(String str){

this.str=str;

this.count=0;

}

public void measure(){

for(int i=0;i

for(int j=i+1;j

if(str.charAt(i)>str.charAt(j)){

count++;

}

}

}

}

}

原文:http://blog.csdn.net/u011479875/article/details/45080309

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值