Automatic Editing - UVa 10115 字符串处理

Problem E: Automatic Editing

Source file:autoedit.{ccppjavapas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop

题意:给你n组替换的数据,然后将最后一行的字符串一次处理,去转换,最后输出结果的字符串。

思路:这个题要是真自己一点一点打的话……我就不说什么了,最好还是利用C++自带的算法吧。

           首先是char *pos1 的意思是定义一个字符指针,然后pos1=strstr(s1,s2),在s1中找到s2所在的位置,应该是第一个匹配的字符所在的位置。

           然后strcpy(s1,s2)将s2复制给s1。

           strcat(s1,s2)将s2加到s1后面。


           另外加一句:以前的时候我总是很讨厌UVa,理由如下:

                    ①UVa题目长,比较啰嗦,没用的话太多。

                    ②UVa的数据输入都很丧失,已经被坑过无数次了,而且有的时候不给数据范围,大家应该都有些许的体会吧。

                    ③UVa的OJ比较脆弱,挂的情况比较多,写完一个程序不能返回结果,就没有心情写下一个了……可能我有些许的强迫症,但是应该或多或少都有些不舒心吧。

              但是后来做着做着题,就发现其实UVa还是比较好的。如果以后正式比赛的时候真的出了这种丧病的数据输入,不就死了么?另外题目长可以锻炼自己的读题能力,和过滤信息的能力。至于挂OJ,我只能说有些比赛确实是不会马上返回结果,所以需要锻炼心理能力【但我还是希望UVa的OJ能够更坚挺更迅速一些。

不扯那么多了,AC代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{ char s1[100],s2[100];
}word[110];
char str[1000],s[1000];
int main()
{ int i,j,k,n;
  char *pos1,*pos2;
  while(~scanf("%d",&n) && n>0)
  { getchar();
    for(i=1;i<=n;i++)
    { gets(word[i].s1);
      gets(word[i].s2);
    }
    gets(str);
    for(i=1;i<=n;i++)
    { pos1=strstr(str,word[i].s1);
      if(pos1==NULL)
       continue;
      k=0;
      for(pos2=str;pos2!=pos1;pos2++)
       s[k++]=*pos2;
      s[k]='\0';;
      pos1+=strlen(word[i].s1);
      strcat(s,word[i].s2);
      strcat(s,pos1);
      strcpy(str,s);
      i--;
    }
    printf("%s\n",str);
  }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值