To the Max - POJ 1050 dp

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39758 Accepted: 21010

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

题意:找到和最大的矩阵并输出最大的和。

思路:我们先看一下如果是一维的怎么办,sum[i]=  sum[i-1]<=0 ?  num[i] :sum[i-1]+num[i]。

           这道题只要把当做是n*(n-1)/2个一维的数,然后去算就可以了,复杂度应该是小于o(n^3),但是最后时间出来是16ms,看来数据比较水。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int num[110];
int res1[110][110];
int res2[110][110];
int main()
{ int n,i,j,k,ans=-100000000;
  scanf("%d",&n);
  for(k=1;k<=n;k++)
  { for(i=1;i<=n;i++)
     scanf("%d",&num[i]);
    for(i=1;i<=n;i++)
     for(j=i;j<=n;j++)
     { res1[i][j]=res1[i][j-1]+num[j];
       if(res2[i][j]<=0)
        res2[i][j]=res1[i][j];
       else
        res2[i][j]=res2[i][j]+res1[i][j];
       if(res2[i][j]>ans)
        ans=res2[i][j];
     }
  }
  printf("%d\n",ans);
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值