Product - UVa 10106 高精度

Product

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444

题意:算大乘法。

思路:感觉这类的东西用java的高精度so easy!!【可能是作死

           虽然JAVA比较慢,但是JAVA的高精度真的很赞。

JAVA AC代码如下:

import java.math.BigInteger;
import java.util.Scanner;

public class Main
{ public static void main(String [] args) 
	{ Scanner scan=new Scanner(System.in);
	  while(scan.hasNextBigInteger())
	  { BigInteger a=scan.nextBigInteger();
	    BigInteger b=scan.nextBigInteger();
	    BigInteger c=b.multiply(a);
	    System.out.println(c);
	  }
	
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值