UVA 10106 Product 高精度运算

 

J - Product
Crawling in process... Crawling failed Time Limit:3000MS    Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


 Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444

 Virtual judge 交不了 uva上不去  无奈用手机开vpn交的 心累

ACcode:

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #define maxn 10000
    using namespace std;
    char a[maxn],b[maxn];
    int ans[maxn*2];
    int main(){
        int lena,lenb;
        while(scanf("%s",a)!=EOF){
            scanf("%s",b);
            if(!strcmp(a,"0")||!strcmp(b,"0")){
                printf("0\n");
                continue;
            }
            memset(ans,0,sizeof(ans));
            lena=strlen(a);
            lenb=strlen(b);
            ans[0]=lena+lenb;
            int t1,t2;
            for(int i=lena;i>0;--i){
                for(int j=lenb;j>0;--j){
                    t1=a[i-1]-'0';
                    t2=b[j-1]-'0';
                    ans[i+j]+=t1*t2;
                }
            }
            for(int i=ans[0];i>0;--i){
                if(ans[i]>10){
                    ans[i-1]+=ans[i]/10;
                    ans[i]%=10;
                }
            }
            int t=1;
            while(ans[t]==0)t++;
            for(int i=t;i<=ans[0];++i)cout<<ans[i];
            putchar('\n');
        }
        return 0;
    }


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值