Alibaba - UVa 1632 dp

Alibaba the famous character of our childhood stories would like to be immortal in order to keep bringing happiness to children. In order to rich this status he needs to prove that he is still able to do some unusual things. There are n treasures, (n<=10000) each in a different place located along a straight road. Each treasure has a time limit, after that it vanishes. Alibaba must take all the n treasures, and he must do it quickly. So he needs to figure out the order in which he should take the treasures before their deadlines starting from the most favorable position. Alibaba has the list of places and deadlines of the treasures. A place i is located at distance di from the leftmost end of the road. The time it takes to take a treasure is instantaneous. Alibaba must find the smallest time by which he can take all the treasures.

Input 

The program input is from a text file. Each data set in the file stands for a particular set of treasures. For each set of treasures the input contains the number of treasures, and the list of pairs place - deadline in increasing order of the locations. White spaces can occur freely between the numbers in the input. The input data are correct.

Output 

For each set of data the program prints the result to the standard output on a separate line. The solution is represented by the smallest time by which Alibaba can take all the treasures before they vanish. If this is not possible then the output is  "No solution" .

Sample Input 

5
1 3
3 1
5 8
8 19
10 15

5
1 5
2 1
3 4
4 2
5 3

Sample Output 

11
No solution

题意:你可以在任意点开始,然后单位时间移动一个单位距离,然后问你能否在每个物品消失前拿到他们,注意当你正好在那个时间拿到是不行的。

思路:dp[i][j][0]表示拿i到j的物品最后停在i点的最少时间,dp[i][j][1]表示拿i到j的物品最后停在j点的最少时间。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[10010][10010][2],num[10010][2];
int main()
{ int n,i,j,k;
  while(~scanf("%d",&n))
  { for(i=1;i<=n;i++)
    { scanf("%d%d",&num[i][0],&num[i][1]);
      dp[i][i][0]=0;dp[i][i][1]=0;
    }
    for(i=n;i>=1;i--)
     for(j=i+1;j<=n;j++)
     { dp[i][j][0]=min(dp[i+1][j][0]+num[i+1][0]-num[i][0],dp[i+1][j][1]+num[j][0]-num[i][0]);
       if(dp[i][j][0]>=num[i][1])
        dp[i][j][0]=1000000000;
       dp[i][j][1]=min(dp[i][j-1][1]+num[j][0]-num[j-1][0],dp[i][j-1][0]+num[j][0]-num[i][0]);
       if(dp[i][j][1]>=num[j][1])
        dp[i][j][1]=1000000000;
     }
     k=min(dp[1][n][0],dp[1][n][1]);
    if(k<1000000000)
     printf("%d\n",k);
    else
     printf("No solution\n");
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值