Another Crisis - UVa 12186 树形dp

A couple of years ago, a new world wide crisis started, leaving many people with economical problems. Some workers of a particular company are trying to ask for an increase in their salaries.

The company has a strict hierarchy, in which each employee has exactly one direct boss, with the exception of the owner of the company that has no boss. Employees that are not bosses of any other employee are calledworkers. The rest of the employees and the owner are called bosses.

To ask for a salary increase, a worker should file a petition to his direct boss. Of course, each boss is encouraged to try to make their subordinates happy with their current income, making the company's profit as high as possible. However, when at least T percent of its direct subordinates have filed a petition, that boss will be pressured and have no choice but to file a petition himself to his own direct boss. Each boss files at most 1 petition to his own direct boss, regardless on how many of his subordinates filed him a petition. A boss only accounts his direct subordinates (the ones that filed him a petition and the ones that didn't) to calculate the pressure percentage.

Note that a boss can have both workers and bosses as direct subordinates at the same time. Such a boss may receive petitions from both kinds of employees, and each direct subordinate, regardless of its kind, will be accounted as 1 when checking the pressure percentage.

When a petition file gets all the way up to the owner of the company, all salaries are increased. The workers' union is desperately trying to make that happen, so they need to convince many workers to file a petition to their direct boss.

Given the company's hierarchy and the parameter T, you have to find out the minimum number of workers that have to file a petition in order to make the owner receive a petition.

Input 

There are several test cases. The input for each test case is given in exactly two lines. The first line contains two integers N and T ( 1$ \le$N$ \le$105 , 1$ \le$T$ \le$100), separated by a single space. N indicates the number of employees of the company (not counting the owner) and T is the parameter described above. Each of the employees is identified by an integer between 1 and N. The owner is identified by the number 0. The second line contains a list of integers separated by single spaces. The integer Bi, at position i on this list (starting from 1), indicates the identification of the direct boss of employee i (0$ \le$Bi$ \le$i - 1).

The last test case is followed by a line containing two zeros separated by a single space.

Output 

For each test case output a single line containing a single integer with the minimum number of workers that need to file a petition in order to get the owner of the company to receive a petition.

Sample Input 

3 100 
0 0 0 
3 50 
0 0 0 
14 60 
0 0 1 1 2 2 2 5 7 5 7 5 7 5 
0 0

Sample Output 

3 
2 
5

题意:在一个树形的结构中,最底层的全是工人,中间的为boss,根为owner。每个工人可以提出一份涨工资的申请,然后每个boss看到至少T%的直系下属提交了申请,他就会往上提交一份申请。当然,owner在这种情况下就会涨工资了。问至少有多少个员工提交申请才能涨工资。

思路:很基础的树形dp,每次搜索他的直系下属提交一个申请需要几个员工,排序后求最小的和,再返回结果。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<algorithm>
using namespace std;
struct node
{ int pos,num;
}worker[100010];
int n;
double p;
vector <int> vc[100010],f;
void dfs(int m)
{ int len=vc[m].size();
  if(len==0)
  { worker[m].num=1;
    return;
  }
  int ans=0,k=ceil(len*p),i;
  for(i=0;i<len;i++)
   dfs(vc[m][i]);
  f.clear();
  for(i=0;i<len;i++)
   f.push_back(worker[vc[m][i]].num);
  sort(f.begin(),f.end());
  for(i=0;i<k;i++)
   ans+=f[i];
  worker[m].num=ans;
}
int main()
{ int i,j,k;
  node a;
  while(~scanf("%d%lf",&n,&p) && n)
  { p/=100;
    for(i=0;i<=n;i++)
     vc[i].clear();
    for(i=1;i<=n;i++)
    { scanf("%d",&k);
      vc[k].push_back(i);
    }
    dfs(0);
    printf("%d\n",worker[0].num);
  }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值