Land Division Tax - POJ 2086 dp

Land Division Tax
Time Limit: 5000MS Memory Limit: 30000K
Total Submissions: 699 Accepted: 308

Description

International Concrete Projects Company (ICPC) is a construction company which specializes in building houses for the high-end market. ICPC is planning a housing development for new homes around a lake. The houses will be built in lots of different sizes, but all lots will be on the lake shore. Additionally, every lot will have exactly two neighbors in the housing development: one to the left and one to the right. 

ICPC owns the land around the lake and needs to divide it into lots according to the housing development plan. However, the County Council has a curious regulation regarding land tax, intended to discourage the creation of small lots: 
  1. land can only be divided using a sequence of land divisions; 
  2. a land division is an operation that divides one piece of land into two pieces of land; and 
  3. for each land division, a land division tax must be paid.

Denoting by A the area of the largest resulting part of the division, the value of the land division tax is A*F, where F is the division tax factor set yearly by the County Council. Note that due to (2), in order to divide a piece of land into N lots, N - 1 land divisions must be performed, and therefore N - 1 payments must be made to the County Council. 
For example, considering the figure above, if the division tax factor is 2.5 and the first land division separates the lot of 500 units of area from the other lots, the land division tax to be paid for this first division is 2.5 * (300 + 200 + 100 + 100 + 100). If the next land division separates the lot of 300 units together with its neighbor lot of 100 units, from the set of the remaining lots, an additional 2.5 * (300 + 100) must be paid in taxes, and so on. Note also that some land divisions are not possible, due to (2). For example, after the first land division mentioned above, it is not possible to make a land division to separate the lot of 300 units together with the lot of 200 units from the remaining three lots, because more than two parts would result from that operation. 
Given the areas of all lots around the lake and the current value of the division tax factor, you must write a program to determine the smallest total land division tax that should be paid to divide the land according to the housing development plan.

Input

The input contains several test cases. The first line of a test case contains an integer N and a real F, indicating respectively the number of lots (1 <= N <= 200) and the land division tax factor (with precision of two decimal digits, 0 < F <= 5.00). The second line of a test case contains N integers Xi, representing the areas of contiguous lots in the development plan (0 < Xi <= 500, for 1 <= i <= N); furthermore, Xk is neighbour to X k+1 for 1 <= k <= N - 1, and X N is neighbour to X1. The end of input is indicated by N = F = 0.

Output

For each test case in the input your program must produce a single line of output, containing the minimum total land division tax, as a real number with precision of two decimal digits.

Sample Input

4 1.50
2 1 4 1
6 2.50
300 100 500 100 100 200
0 0

Sample Output

13.50
4500.00

题意:你每次需要将一个大的区域分成两部分,每次的费用是税率*分割后的两块地中最大的面积。

思路:将环形转化成一维的,然后dp[i][j]表示分割i到j块地所需的价钱,dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+max(s[k]-s[i-1],s[j]-s[k]))。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[410][410],val[410],s[410],INF=1e9;
int main()
{ int n,N,i,j,k,len,ans;
  double p;
  while(~scanf("%d%lf",&n,&p) && n)
  { for(i=1;i<=n;i++)
    { scanf("%d",&val[i]);
      val[i+n]=val[i];
    }
    N=n*2;
    for(i=1;i<=N;i++)
    { dp[i][i]=0;
      s[i]=s[i-1]+val[i];
    }
    for(len=1;len<n;len++)
     for(i=1;i+len<=N;i++)
     { j=i+len;
       dp[i][j]=INF;
       for(k=i;k<j;k++)
        dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+max(s[k]-s[i-1],s[j]-s[k]));
     }
    ans=INF;
    for(i=1;i<=n;i++)
     ans=min(ans,dp[i][i+n-1]);
    printf("%.2f\n",ans*p);
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值