Rotating Scoreboard - POJ 3335 半平面交

39 篇文章 0 订阅

Rotating Scoreboard
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5709 Accepted: 2261

Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You may view spectator's seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard (a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 ... xn yn where n (3 ≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integers xi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input

2
4 0 0 0 1 1 1 1 0
8 0 0  0 2  1 2  1 1  2 1  2 2  3 2  3 0

Sample Output

YES
NO

题意:按顺时针给定一个多边形,判断是否存在一个内部点可以看到所有的点。

思路:就是半平面交,判断是否有点即可。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double eps=1e-9;
struct Point
{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y){}
};
Point points[110],p[110],q[110];
int T,t,n,m,cCnt,curCnt;
void init()
{
    int i;
    for(i=1;i<=n;i++)
       p[i]=points[i];
    p[0]=p[n];p[n+1]=p[1];
    cCnt=n;
}
void getline(Point x,Point y,double &a,double &b,double &c)
{
    a=y.y-x.y;
    b=x.x-y.x;
    c=y.x*x.y-y.y*x.x;
}
Point InterSection(Point x,Point y,double a,double b,double c)
{
    double u=fabs(a*x.x+b*x.y+c);
    double v=fabs(a*y.x+b*y.y+c);
    return Point((x.x*v+y.x*u)/(u+v),(x.y*v+y.y*u)/(u+v));
}
void cut(double a,double b,double c)
{
    int i;
    curCnt=0;
    for(i=1;i<=cCnt;i++)
       if(a*p[i].x+b*p[i].y+c>=0)
         q[++curCnt]=p[i];
       else
       {
           if(a*p[i-1].x+b*p[i-1].y+c>0)
             q[++curCnt]=InterSection(p[i-1],p[i],a,b,c);
           if(a*p[i+1].x+b*p[i+1].y+c>0)
             q[++curCnt]=InterSection(p[i],p[i+1],a,b,c);
       }
    for(i=1;i<=curCnt;i++)
       p[i]=q[i];
    p[0]=p[curCnt];p[curCnt+1]=p[1];
    cCnt=curCnt;
}
int solve()
{
    init();
    int i,j;
    double a,b,c,k;
    for(i=1;i<=n;i++)
    {
        getline(points[i],points[i+1],a,b,c);
        cut(a,b,c);
    }
    if(cCnt<=0)
      return 0;
    return 1;
}
int main()
{
    int i,j,k;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
           scanf("%lf%lf",&points[i].x,&points[i].y);
        points[0]=points[n];points[n+1]=points[1];
        k=solve();
        if(k>0)
          printf("YES\n");
        else
          printf("NO\n");
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值