2577 HUD (动态规划)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2577


看别人代码做了这个题,感觉dp好强大,很震撼,哎,我还是太年轻了,学的太少了


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

 定义两个数组,一个是始终开的状态,一个是始终关的状态,然后就相互转化去改状态最小值,千万要记得可以用 Shift   键啊!!!!

解释在代码中,




#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

#define N 105

int a[N];  //Num  Lock 键始终开
int b[N];  //Num  Lock 键始终关

inline int min(int a,int b)
{
    return a<b?a:b;
}

int main()
{
    char c[N];

    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",c+1);  //方便而已,自己猜测吧

        int len=strlen(c+1);  //如果是strlen(c),len=0;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        a[0]=1;  //打开Num  Lock 键

        for(i=1;i<=len;i++)
            if(c[i]>='a'&&c[i]<='z')
            {
                a[i]=min(a[i-1]+2,b[i-1]+2);  
                      //Shift+字母    字母+Num  Lock 键
                b[i]=min(a[i-1]+2,b[i-1]+1);
                     //Num Lock键+字母   字母     
            }
            else
            {
                a[i]=min(a[i-1]+1,b[i-1]+2);  //同理
                b[i]=min(a[i-1]+2,b[i-1]+2);
            }

            a[len]++; //关掉Num Lock键

            int ans=min(a[len],b[len]);
            printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值