HDU 2795 Billboard 贴广告(线段树)


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 


贴广告,每次贴左上角(如果可以),线段树的le  ri,保存的是行,因为题目要求输出来广告贴的是第几行,f[pos].va保存的

是从le到ri的(这么多行的)每行剩余宽度的最大值(用来判断是否能贴这个广告),还要注意的是最上面的一行是第一行


后面还有一个要注意的地方在代码提示


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N 200005

int h,n,w;
int ans;

struct stud{
int le,ri;
int len;
}f[N*4];

void build(int pos,int le,int ri)
{
    f[pos].le=le;
    f[pos].ri=ri;
    f[pos].len=w;
    if(le==ri)  return ;

    int mid=MID(le,ri);

    build(L(pos),le,mid);
    build(R(pos),mid+1,ri);
}

void query(int pos,int va)
{
   if(f[pos].le==f[pos].ri)
   {
       f[pos].len-=va;
       ans=f[pos].le;
       return ;
   }

   if(f[L(pos)].len>=va)
       query(L(pos),va);
   else
       query(R(pos),va);
       
    //下面是我犯错误的一个地方,因为我原来是定义 query 为int 返回值,
    //那样就不会进行下面这一步了(因为已经返回了)

    f[pos].len=max(f[L(pos)].len,f[R(pos)].len);
}

int main()
{
    while(~scanf("%d%d%d",&h,&w,&n))
    {
        if(h>n) h=n;

        build(1,1,h);

        int m=n;
        int len;

        while(m--)
        {
            scanf("%d",&len);

            if(f[1].len>=len)
            {
                query(1,len);
                printf("%d\n",ans);
            }
            else
                printf("-1\n");
        }
    }
    return 0;
}






  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值