HDU 3974 Assign the task(线段树 单点更新+lazy)

Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
  
  
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
  
  
Case #1: -1 1 2
 

Source

题意:先输入n个人,然后是n个人的关系(下属 上司),然后分配任务,每一个上司分到一个任务就把任务给他的所有下属做,即她的下属的任务都是这个任务,任务不会平分,

查询一个人该时刻做的任务


思路:先找到树根,然后dfs求出每一个人控制的编号,然后每次查询时查询该人控制的下属范围,然后就是lazy,记录该人的任务是否已经传递下去了



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 50005

int father[N],num;
vector<int>g[N];

int le[N],ri[N];

struct stud{
int le,ri;
int va;
int lazy;
}f[N*4];

int cha(int x)
{
	if(x!=father[x])
		father[x]=cha(father[x]);
	return father[x];
}

void dfs(int x)
{
    int i;
	le[x]=++num;

	fre(i,0,g[x].size())
	{
		dfs(g[x][i]);
	}
    ri[x]=num;
}

void pushdown(int pos)
{
	if(f[pos].va==-1) return ;
	if(f[pos].lazy==0) return ;

	f[L(pos)].va=f[pos].va;
	f[R(pos)].va=f[pos].va;
	f[L(pos)].lazy=f[R(pos)].lazy=1;
    f[pos].lazy=0;
}

void build(int pos,int le,int ri)
{
	f[pos].le=le;
	f[pos].ri=ri;
	f[pos].lazy=0;
	f[pos].va=-1;
	if(le==ri) return ;

	int mid=MID(le,ri);

	build(L(pos),le,mid);
	build(R(pos),mid+1,ri);
}

void update(int pos,int le,int ri,int va)
{
	if(f[pos].le==le&&f[pos].ri==ri)
	{
		f[pos].va=va;
		f[pos].lazy=1;
		return ;
	}

    pushdown(pos);

    int mid=MID(f[pos].le,f[pos].ri);

    if(mid>=ri)
		update(L(pos),le,ri,va);
	else
	 if(mid<le)
		update(R(pos),le,ri,va);
	else
	{
		update(L(pos),le,mid,va);
		update(R(pos),mid+1,ri,va);
	}
}

int query(int pos,int le)
{
	if(f[pos].le==le&&f[pos].ri==le)
		return f[pos].va;

	pushdown(pos);

	int mid=MID(f[pos].le,f[pos].ri);

	if(mid>=le)
		return query(L(pos),le);
    return query(R(pos),le);
}


int main()
{
	int i,j,t,m,n,ca=0;
	sf(t);
	while(t--)
	{
		sf(n);
		fre(i,1,n+1)
		{
			father[i]=i;
			g[i].clear();
		}
        int u,v;
        m=n-1;
        while(m--)
		{
			sff(u,v);
			father[u]=v;
			g[v].push_back(u);
		}

       u=cha(1);
       num=0;

       dfs(u);


       build(1,1,num);

       sf(m);

       pf("Case #%d:\n",++ca);

       char op[10];

       while(m--)
	   {
	   	  scanf("%s",op);
	   	  if(op[0]=='C')
		  {
		  	sf(u);
		  	pf("%d\n",query(1,le[u]));
		  }
          else
		  {
		  	 sff(u,v);
		  	 update(1,le[u],ri[u],v);
		  }
	   }
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值