Goldbach`s Conjecture

Description

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

#include<stdio.h>
#include<string.h>
bool b[10000005]={0};//不能是int
int a[1000005]={0};
void init()
{
	int i,j;
	for(i=2;i<=10000003;i++)
    {
        if(!b[i])
            for(j=i+i;j<=10000003;j+=i)
				b[j]=1;
    }
    j=1;
    for(i=2;i<=10000003;i++)
        if(b[i]==0)
			a[j++]=i;
}
int main()
{
    int i,j,m,n,ca=1,t;
	init();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        m=0;
        for(i=1;i<=1000002;i++)
        {
            if(a[i]>n/2)break;
            if(b[n-a[i]]==0)m++;
        }
        printf("Case %d: %d\n",ca++,m);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值