F - Goldbach`s Conjecture (哥德巴赫猜想)

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

题解:暴力肯定T,一个素数表也T,再加个vis就A了。

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
const int N=10000000;
int isprime[700000];  //从前往后存素数值
bool vis[N];        //判断素数
int tot;
void prime()
{
    memset(vis,1,sizeof(vis));  //初始化为1
    vis[1]=0;
    for(int i=2;i<N;i++)
    {
        if(vis[i])      //vis[i]标记的就是素数,放入素数数组即可
            isprime[tot++]=i;
        for(int j=0;j<tot;j++)//将每个素数的i倍标记为1
        {
            if(i*isprime[j]>=N)  //边缘条件,一定要加,不然会RE
                break;
            vis[i*isprime[j]]=0; //该数一定有因子,取消标记
            //if(i%isprime[j]==0) //这两行剪枝,可不要
               // break;
        }
    }
}
int main()

{
    int t,k=1;
    scanf("%d",&t);
    prime();
    while(t--)
    {
        int x;
        int sum=0;
        scanf("%d",&x);
        for(int i=0; isprime[i]<=x/2; i++)
        {
            if(vis[x-isprime[i]])  //从头开始判断素数,isprime[i]一定是素数,只需判断x-isprime是否为素数即可
                sum++;
        }
        cout<<"Case "<<k++<<": "<<sum<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值