poj 2155 Matrix

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18621 Accepted: 7022

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng
 
      本题为树状数组的二维应用,矩阵中每个点的值为0或1,因此只要求出某点的反转次数对2取模即可。因为本题是对矩阵反转,分别以四个顶点反转就可以,具体有两种反转方法。一种是从左上角的(0,0)点到(x,y)之间的矩阵反转,另一种是从右下角(N,N)到(x,y)反转,假设矩阵长为N。两种反转最终效果一样,都是所求区域反转一次,其他区域反转回原来状态,保持不变,建义动手画画图,很明显。因此本题可以用两种解题方法做,具体如下:
 
方法一:从点(x,y)到右下角(N,N)更新
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define FOR(a,b) for(int i =  a ; i < b ; i++)
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define FOPENIN(IN) freopen(IN, "r", stdin)
#define FOPENOUT(OUT) freopen(OUT, "w", stdout)
int N,T;
int c[1010][1010];
int lowbit(int x ){
    return x&(-x);
}
int Getsum(int x,int y){
    int ans = 0 ;
    for(int i = x ; i > 0 ; i-=lowbit(i))
        for(int j = y ; j > 0  ; j-=lowbit(j))
            ans += c[i][j];
    return ans ;
}
void add(int x,int y){
    for(int i = x ; i <=N  ; i+=lowbit(i))
        for(int j = y ; j <= N ; j += lowbit(j))
            c[i][j]+=1;
}
int main()
{
    int X,x,y,x1,y1,x2,y2;
    char cc;
    scanf("%d",&X);
    while(X--){
        mem0(c);
        scanf("%d%d",&N,&T);
        while(T--){
            cin>>cc;
            if(cc=='Q'){
                scanf("%d %d",&x,&y);
                printf("%d\n",Getsum(x,y)%2);
            }
            else if(cc=='C'){
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                add(x1,y1);
                add(x1,y2+1);
                add(x2+1,y1);
                add(x2+1,y2+1);
            }
        }
          puts("");
    }
//    system("pause");
    return 0;
}
方法二:从左上角(0,0)到结点(x,y)更新
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define FOR(a,b) for(int i =  a ; i < b ; i++)
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define FOPENIN(IN) freopen(IN, "r", stdin)
#define FOPENOUT(OUT) freopen(OUT, "w", stdout)
int N,T;
int c[1010][1010];
int lowbit(int x ){
    return x&(-x);
}
int Getsum(int x,int y){
    int ans = 0 ;
    for(int i = x ; i <= N ; i+=lowbit(i))
        for(int j = y ; j <= N  ; j+=lowbit(j))
            ans += c[i][j];
    return ans ;
}
void add(int x,int y){
    for(int i = x ; i >0 ; i-=lowbit(i))
        for(int j = y ; j > 0  ; j -= lowbit(j))
            c[i][j]+=1;
}
int main()
{
    int X,x,y,x1,y1,x2,y2;
    char cc;
    scanf("%d",&X);
    while(X--){
        mem0(c);
        scanf("%d%d",&N,&T);
        while(T--){
            cin>>cc;
            if(cc=='Q'){
                scanf("%d %d",&x,&y);
                printf("%d\n",Getsum(x,y)%2);
            }
            else if(cc=='C'){
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                add(x1-1,y1-1);
                add(x1-1,y2);
                add(x2,y1-1);
                add(x2,y2);
            }
        }
          puts("");
    }
//    system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值