2018_2_1_Integer Inquiry_大数基础题

13 篇文章 0 订阅
Integer Inquiry
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35350 Accepted: 13778

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source

East Central North America 1996
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cctype>
#include<cstring>

using namespace std;

const int N=500+10;

struct bignumber{
private:
	int a[N];
	int len;
public:
	bignumber(){
		memset(a,0,sizeof(a));
		len=1;
	}
	int length(){
		return len;
	}
	int at(int k){
		if(0<=k&&k<len)return a[k];
		return -1;
	}
	void setnum(char s[]){
		len=0;
		for(int i=strlen(s)-1;i>=0;i--)
		a[len++]=s[i]-'0';
	}
	bool iszero(){
		return len==1&&a[0]==0;
	}
	void add(bignumber &x){
		for(int i=0;i<x.len;i++){
			a[i]+=x.a[i];
			a[i+1]+=a[i]/10;
			a[i]%=10;
		}
		int k=x.len;
		while(a[k]){
			a[k+1]+=a[k]/10;
			a[k]%=10;
			k++;
		}
		len=k;
	}
	
};

char s[N],t[N];
bignumber a,b;
int main(){
	gets(s);
	a.setnum(s);
	while(gets(t)){
		if(!strcmp(t,"0"))
		break;
		b.setnum(t);
		a.add(b);
	}
	for(int i=a.length()-1;i>=0;i--)
	printf("%d",a.at(i));
	printf("\n");
	return 0;
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值