POJ – 1503 Integer Inquiry Integer Inquiry

POJ –1503 Integer Inquiry

Integer Inquiry

Time Limit: 1000MS

Memory Limit: 10000K

Total Submissions: 34728

Accepted: 13523

Description

One of the firstusers of BIT's new supercomputer was Chip Diller. He extended his explorationof powers of 3 to go from 0 to 333 and he explored taking various sums of thosenumbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were hereto see these results.'' (Chip moved to a new apartment, once one becameavailable on the third floor of the Lemon Sky apartments on ThirdStreet.) 

Input

The input willconsist of at most 100 lines of text, each of which contains a single VeryLongInteger.Each VeryLongInteger will be 100 or fewer characters in length, and will onlycontain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your programshould output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

Sample Output

370370367037037036703703703670

大数加法----》直接用java中的BigInteger应该时最快的方法,不过我这里通过数组实现:

将大数的每位分配到数组中的每一位然后相加。

 

代码:

//poj 1503 Integer Inquiry
#include <cstdio>
#include <cstring>
const int max = 200;
int main(int argc,char const *argv[])
{
    //freopen("in.txt","r", stdin);
    int sum[max];
    memset(sum,0, sizeof sum);
    char line[150];
    //waring the gets
    while (gets(line)&& !(line[0]== '0'&&line[1]== '\0')){
        int s =0, c= 0;
        int n =0, j= max -1;
        while (line[n++]);
        n -= 2;
        while (n >= 0) {
            int tmp = line[n]- '0';
            s = sum[j]+ tmp + c;
            c = s/ 10;
            sum[j]= s %10;
            n--; j--;
        }
        while (c) {
            s = sum[j]+ c;
            c = s/ 10;
            sum[j--]= s %10;
        }
    }
    for (int i =0; i< max; i++){
        if (sum[i]){
            for (; i < max; i++)
                printf("%d", sum[i]);
        }
    }
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值