2018_2_7_Ultra-QuickSort 借用快排思想

12 篇文章 0 订阅
Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 65980 Accepted: 24682

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05
#include<iostream>
#include<cstdio>
using namespace std;

const int N=1e6;
int p[N],o[N];
long long count;

void sort(int a,int b){
	if(a>=b)return;
	int mp=p[a+(b-a)/2];
	int mdi,i;
	for(mdi=i=a;i<b;i++)
	if(p[i]<mp)mdi++;
	int below=mdi-a;
	int ni;
	for(ni=i=a;i<b;i++)
	if(p[i]<mp){
		o[ni++]=p[i];
		below--;
	}else{
		o[mdi++]=p[i];
		count+=below;
	}
	for(mdi=a;o[mdi]!=mp;mdi++);
	for(mdi;mdi&&o[mdi-1]>mp;mdi--){
		swap(o[mdi],o[mdi-1]);
		count++;
	}
	for(i=a;i<b;i++)p[i]=o[i];
	sort(a,mdi);
	for(mdi;mdi<b&&p[mdi]==mp;mdi++);
	sort(mdi,b);
}



int main(){
	int n;
	while(scanf("%d",&n),n){
		for(int i=0;i<n;i++)
		scanf("%d",p+i);
		count=0;
		sort(0,n);
		cout<<count<<endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值