Trees Made to Order_catalan数_2018_2_17

16 篇文章 0 订阅
3 篇文章 0 订阅

Trees Made to Order
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7474 Accepted: 4264

Description

We can number binary trees using the following scheme:
The empty tree is numbered 0.
The single-node tree is numbered 1.
All binary trees having m nodes have numbers less than all those having m+1 nodes.
Any binary tree having m nodes with left and right subtrees L and R is numbered n such that all trees having m nodes numbered > n have either Left subtrees numbered higher than L, or A left subtree = L and a right subtree numbered higher than R.

The first 10 binary trees and tree number 20 in this sequence are shown below:

Your job for this problem is to output a binary tree when given its order number.

Input

Input consists of multiple problem instances. Each instance consists of a single integer n, where 1 <= n <= 500,000,000. A value of n = 0 terminates input. (Note that this means you will never have to output the empty tree.)

Output

For each problem instance, you should output one line containing the tree corresponding to the order number for that instance. To print out the tree, use the following scheme:

A tree with no children should be output as X.
A tree with left and right subtrees L and R should be output as (L')X(R'), where L' and R' are the representations of L and R.
If L is empty, just output X(R').
If R is empty, just output (L')X.

Sample Input

1
20
31117532
0

Sample Output

X
((X)X(X))X
(X(X(((X(X))X(X))X(X))))X(((X((X)X((X)X)))X)X)

Source

#include<iostream>
#include<cstdio>
using namespace std;

const int N=20;
int cal[N]={1,1},sum[N]={0,1};

int count(int &n){
	int t=1;
	while(n>cal[t]){
		n-=cal[t];
		t++;
	}
	return t;
}

void print(int all,int m){
	int r=all-1;
	int l=0;
	while(m>cal[r]*cal[l]){
		m-=cal[r]*cal[l];
		--r;
		++l;
	}
	int k;
	if(l>0){
		putchar('(');
		k=m/cal[r];
		if(m%cal[r]!=0)k++;
		print(l,k);
		putchar(')');
	}
	putchar('X');
	if(r>0){
		putchar('(');
		k=(m-1)%cal[r]+1;
		print(r,k);
		putchar(')');
	}
}

int main(){
	for(int i=2;i<19;i++){
		for(int j=0;j<i;j++)
		cal[i]+=cal[j]*cal[i-1-j];
		sum[i]=cal[i]+sum[i-1];
	}
	int n;
	while(scanf("%d",&n),n){
		int nodenumber=count(n);
		print(nodenumber,n);puts("");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值