A Knight's Journey_dfs_2018_2_24

11 篇文章 0 订阅
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
 
#include<iostream>
#include<cstring>
using namespace std;

const int d[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};
int ansx[30],ansy[30];
bool vis[30][30];
bool f;
int n,m;

void dfs(int x,int y,int now){
	if(now==n*m&&!f){
		for(int i=1;i<=m*n;i++)
		printf("%c%d",ansx[i]+64,ansy[i]);
		puts("\n");
		f=1;return;
	}if(f)return;
	int nx,ny;
	for(int i=0;i<8;i++){
		nx=x+d[i][0];
		ny=y+d[i][1];
		if(vis[nx][ny]||nx<=0||ny<=0||nx>m||ny>n)continue;
		vis[nx][ny]=1;
		ansx[now+1]=nx;
		ansy[now+1]=ny;
		dfs(nx,ny,now+1);
		vis[nx][ny]=0;
	}
}


int main(){
	int z;
	scanf("%d",&z);
	ansx[1]=1;
	ansy[1]=1;
	for(int i=1;i<=z;i++){
		printf("Scenario #%d:\n",i);
		f=false;
		scanf("%d%d",&n,&m);
		memset(vis,0,sizeof(vis));
		vis[1][1]=1;
		dfs(1,1,1);
		if(!f)puts("impossible\n");
	}
} 

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值