A Knight‘s Journey(DFS模版题)

这篇博客介绍了如何使用深度优先搜索(DFS)解决一个棋盘上的骑士路径问题。在一个小于8x8的矩形棋盘上,骑士需要访问每个格子一次。题目要求找到字典序最小的路径。博客提供了C++代码实现,并展示了样例输入和输出。当无法找到满足条件的路径时,输出'不可能'。此问题涉及图论和回溯算法,是典型的DFS模板题。
摘要由CSDN通过智能技术生成

A Knight’s Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input

3
1 1
2 3
4 3
Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

典型的DFS模版题
这里需要注意字典序:题目输出是先输出列,再输出行,所以列应该是由小到大变化。(光看图很容易误导)
还要注意当遍历一条路径后如果不满足条件,回溯时需要取消该点的标记。

#include<iostream>
#include<cmath>
#include<cstring>
#include<queue>
#include<vector>

using namespace std;
const int MAXN = 8;
int visit[MAXN][MAXN];
int p,q;
int dp[8][2]= {-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};

struct node
{
    int row;
    char col;
}path[MAXN*MAXN];
bool dfs(int x ,int y, int step){
    path[step].row = x + 1;
    path[step].col = y + 'A';
    if(step == p * q){
        for (int i = 1; i <= p*q; ++i)
        {
            cout<<path[i].col<<path[i].row;
        }
        return true;
    }
    for (int i = 0; i < 8; ++i)
    {
        int dx = x + dp[i][0];
        int dy = y + dp[i][1];
        if(dx >= 0 && dx <= p-1 && dy >= 0 && dy <= p-1 && !visit[dx][dy]){
            visit[dx][dy] = 1;
            if(dfs(dx,dy,step+1)){
                return true;
            }
            visit[dx][dy] = 0;

        }
    }
    return false;
}
int main(int argc, char const *argv[])
{
    int n;
    cin>>n;
    for (int i = 1; i <= n; ++i)
    {
        cin>>p>>q;
        memset(visit,0,sizeof(visit));
        cout<<"Scenario #"<<i<<":"<<endl;
        visit[0][0] = 1;
        if(!dfs(0,0,1)){//p:row,q:col
            cout<<"impossible";
        }      
        cout<<endl<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值