1021. Deepest Root (25)_2018_3_25

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components

提交代码

#include<bits/stdc++.h>
using namespace std;

const int N=1e5+10;

vector<int> v[N];
int f[N];
bool vis[N];
int d[N];


int find(int x){
	if(f[x]==-1)return x;
	return f[x]=find(f[x]);
}

int dfs(int s){
	int ans=0;
	if(vis[s])return 0;
	vis[s]=true;
	for(auto u:v[s]){
		if(!vis[u])
		ans=max(ans,dfs(u));
	}
	return ans+1;
}

int main(){
	int n;
	scanf("%d",&n);
	memset(f,-1,sizeof(f));
	for(int i=1;i<n;i++){
		int x,y;
		scanf("%d%d",&x,&y);
		v[x].push_back(y);
		v[y].push_back(x);
		x=find(x);
		y=find(y);
		if(x!=y)
		f[y]=x;
	}
	int sum=0;
	for(int i=1;i<=n;i++)
	if(find(i)==i)sum++;
	if(sum>1){
		printf("Error: %d components\n",sum);return 0;
	}
	int mm=-1;
	for(int i=1;i<=n;i++){
		memset(vis,0,sizeof(vis));
		d[i]=dfs(i);
		mm=max(mm,d[i]);
	}
	bool f=false;
	for(int i=1;i<=n;i++)
	if(d[i]==mm){
		printf("%d\n",i);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值