Matrix Chain Multiplication _dp

4 篇文章 0 订阅

Matrix-chain Multiplication

The goal of the matrix-chain multiplication problem is to find the most efficient way to multiply given n

matrices M1,M2,M3,...,Mn

.

Write a program which reads dimensions of Mi

, and finds the minimum number of scalar multiplications to compute the maxrix-chain multiplication M1M2...Mn

.

Input

In the first line, an integer n

is given. In the following n lines, the dimension of matrix Mi ( i=1...n) is given by two integers r and c which respectively represents the number of rows and columns of Mi

.

Output

Print the minimum number of scalar multiplication in a line.

Constraints

  • 1n100

1r,c100

Sample Input 1

6
30 35
35 15
15 5
5 10
10 20
20 25

Sample Output 1

15125


#include<bits/stdc++.h>

using namespace std;

const int N(100+10);

int p[N];
int m[N][N];
int main(){
    freopen("in.txt","r",stdin);
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    cin>>p[i-1]>>p[i];

    for(int d=2;d<=n;d++)
    for(int i=1;i<=n-d+1;i++){
        int j=i+d-1;
        m[i][j]=(1<<21);
        for(int k=i;k<=j-1;k++)
        m[i][j]=min(m[i][j],m[i][k]+m[k+1][j]+p[i-1]*p[k]*p[j]);
    }
    cout<<m[1][n]<<endl;

    fclose(stdin);
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值