UVA 127 "Accordian" Patience

Description

Download as PDF


 ``Accordian'' Patience 

You are to simulate the playing of games of ``Accordian'' patience, the rules for which are as follows:

Deal cards one by one in a row from left to right, not overlapping. Whenever the card matches its immediate neighbour on the left, or matches the third card to the left,  it may be moved onto that card. Cards match if they are of the same suit or same rank. After making a move, look to see if it has made additional moves possible. Only the top card of each pile may be moved at any given time. Gaps between piles should be closed up as soon as they appear by moving all piles on the right of the gap one position to the left. Deal out the whole pack, combining cards towards the left whenever possible. The game is won if the pack is reduced to a single pile.

Situations can arise where more than one play is possible. Where two cards may be moved, you should adopt the strategy of always moving the leftmost card possible. Where a card may be moved either one position to the left or three positions to the left, move it three positions.

Input

Input data to the program specifies the order in which cards are dealt from the pack. The input contains pairs of lines, each line containing 26 cards separated by single space characters. The final line of the input file contains a # as its first character. Cards are represented as a two character code. The first character is the face-value (A=Ace, 2-9, T=10, J=Jack, Q=Queen, K=King) and the second character is the suit (C=Clubs, D=Diamonds, H=Hearts, S=Spades).

Output

One line of output must be produced for each pair of lines (that between them describe a pack of 52 cards) in the input. Each line of output shows the number of cards in each of the piles remaining after playing ``Accordian patience'' with the pack of cards as described by the corresponding pairs of input lines.

Sample Input

QD AD 8H 5S 3H 5H TC 4D JH KS 6H 8S JS AC AS 8D 2H QS TS 3S AH 4H TH TD 3C 6S
8C 7D 4C 4S 7S 9H 7C 5D 2S KD 2D QH JD 6D 9D JC 2C KH 3D QC 6C 9S KC 7H 9C 5C
AC 2C 3C 4C 5C 6C 7C 8C 9C TC JC QC KC AD 2D 3D 4D 5D 6D 7D 8D TD 9D JD QD KD
AH 2H 3H 4H 5H 6H 7H 8H 9H KH 6S QH TH AS 2S 3S 4S 5S JH 7S 8S 9S TS JS QS KS
#

Sample Output

6 piles remaining: 40 8 1 1 1 1
1 pile remaining: 52
题目大概意思,有很多牌,从左到右不重叠地放在桌面上,如果当前牌和相邻左边第一张或第三张牌匹配(花色或者值相同)就把当前的牌压在左边的那堆牌上,依此类推,直到无法移动牌为止。
思路:模拟呗,刚开始用vector做,速度慢啊2000多MS,后来改成list做,各种操蛋报错,还是1A,1000M,还是比
蒲贵宇用C语言慢,他600MS。
LIST版:
language:c++
code:
#include<iostream>
#include<stack>
#include<list>
#include<cstdio>

using namespace std;

struct card
{
    char x,y;
    card(char a,char b):x(a),y(b) {}
};

bool judge(card a,card b)
{
    if(a.x==b.x||a.y==b.y)return true;
    return false;
}

list<stack<card> >::iterator pre3(const list<stack<card> >::iterator i)
{
    list<stack<card> >::iterator a=i;
    return ------a;
}

list<stack<card> >::iterator pre1(const list<stack<card> >::iterator i)
{
    list<stack<card> >::iterator a=i;
    return --a;
}

int main()
{
    char s[3];
    list<stack<card> > cards;
    list<stack<card> >::iterator i;
    while(scanf("%s",s),s[0]!='#')
    {
        card c(s[0],s[1]);
        stack<card>temp;
        temp.push(c);
        cards.push_back(temp);
        if(cards.size()==52)
        {
            bool ismoved=1;
            while(ismoved)
            {
                ismoved =false;
                size_t count;
                for(i=cards.begin(),count=0; i!=cards.end(); i++,count++)
                {
                    if(count>2&&judge(i->top(),pre3(i)->top()))
                    {
                        pre3(i)->push(i->top());
                        i->pop();
                        ismoved=true;
                        if(i->empty())
                            cards.erase(i);
                        break;
                    }
                    if(count>0&&judge(i->top(),pre1(i)->top()))
                    {
                        pre1(i)->push(i->top());
                        i->pop();
                        ismoved=true;
                        if(i->empty())
                            cards.erase(i);
                        break;
                    }
                }
            }
            if(cards.size()==1)
                printf("%d pile remaining:",cards.size());
            else
                printf("%d piles remaining:",cards.size());
            for(i=cards.begin(); i!=cards.end(); i++)
            {
                printf(" %d",i->size());
            }
            printf("\n");
            ismoved=true;
            cards.clear();
        }
    }
    return 0;
}

vector版:
language:c++
code:
#include<iostream>
#include<stack>
#include<vector>
#include<cstdio>

using namespace std;

struct card
{
    char x,y;
    card(char a,char b):x(a),y(b) {}
};

bool judge(card a,card b)
{
    if(a.x==b.x||a.y==b.y)return true;
    return false;
}

int main()
{
    char s[3];
    bool ismoved=1;
    vector<stack<card> > cards;
    while(scanf("%s",s),s[0]!='#')
    {
        card c(s[0],s[1]);
        stack<card>temp;
        temp.push(c);
        cards.push_back(temp);
        if(cards.size()==52)
        {
            while(ismoved)
            {
                size_t i;
                ismoved =false;
                for(i=0; i<cards.size(); i++)
                {
                    if(i>2&&judge(cards[i].top(),cards[i-3].top()))
                    {
                        cards[i-3].push(cards[i].top());
                        cards[i].pop();
                        ismoved=true;
                        if(cards[i].empty())
                            cards.erase(cards.begin()+i);
                        break;
                    }
                    if(i>0&&judge(cards[i].top(),cards[i-1].top()))
                    {
                        cards[i-1].push(cards[i].top());
                        cards[i].pop();
                        ismoved=true;
                        if(cards[i].empty())
                            cards.erase(cards.begin()+i);
                        break;
                    }
                }
            }
            if(cards.size()==1)
                printf("%d pile remaining:",cards.size());
            else
                printf("%d piles remaining:",cards.size());
            for(size_t i=0; i!=cards.size(); i++)
            {
                printf(" %d",cards[i].size());
            }
            printf("\n");
            ismoved=true;
            cards.clear();
        }
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值