cirs

题目

时间限制: 1 Sec 内存限制: 128 MB

题目描述
Czyzoiers 都想知道小 x 为什么对鸡蛋饼情有独钟。经过一番逼问,小 x 道出了实情:因为他喜欢圆。
最近小 x 又发现了一个关于圆的有趣的问题:在圆上有2N 个不同的点,小 x 想用 N 条线段把这些点连接起来(每个点只能连一条线段),使所有的线段都不想交,他想知道这样的连接方案有多少种?

输入
有且仅有一个正整数 N(N≤3000)。

输出
要求的方案数(结果 mod 100000007)。

样例输入
2
样例输出
2
提示
1 号点与 2 号点连接:2 种。
1 号点与 4 号点连接:1 种。
1 号点与 6 号点连接:2 种。


题意

就是说,给一个数n,一个圆上有2*n个点,然后问有几种方法可以用n条不相交的线段把这2*n个点连接起来。


思路

分治 加 动态规划,枚举从第一个点开始找第偶数个点,连成一条线段,之后这条线段两边有偶数个点(计为x,y),把这x,y各看作是两个圆上的点,即当n=x/2时和n=y/2时的情况,加一个数组记忆化,实现DP。
代码实现如下。

//Time:12 ms
//Memory:1808 kb
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cstring>
using namespace std;

int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt","r",stdin);
#endif // ONLINE_JUDGE
    long long int n,a[30005];
    memset(a,0,sizeof(a));
    a[0]=1;
    a[1]=1;
    a[2]=2;
    a[3]=5;
    cin>>n;
    for(int i=4;i<=n;++i)
    {
        int x=2*i;
        int y,z;
        for(int j=2;j<=x;j+=2)
        {
            y=(j-2)/2;
            z=(x-j)/2;
            a[i]+=a[y]*a[z];
            a[i]%=100000007;
        }
    }
    cout<<a[n]<<endl;
    return 0;
}
Unlike the classical encryption schemes,keys are dispensable in certain PLS technigues, known as the keyless secure strat egy. Sophisticated signal processing techniques such as arti- ficial noise, beamforming,and diversitycan be developed to ensure the secrecy of the MC networks.In the Alice-Bob-Eve model, Alice is the legitimate transmitter, whose intended target is the legitimate receiver Bob,while Eve is the eavesdropper that intercepts the information from Alice to Bob.The secrecy performance is quantified via information leakagei.ethe dif ference of the mutual information between the Alice-Bob and Alice-Eve links. The upper bound of the information leakage is called secrecy capacity realized by a specific distribution of the input symbols, namely,capacity-achieving distribution.The secrecy performance of the diffusion-based MC system with concentration shift keying(CSK)is analyzed from an informa- tion-theoretical point of view,providing two paramount secrecy metrics, i.e., secrecy capacity and secure distance[13].How ever, only the estimation of lower bound secrecy capacity is derived as both links attain their channel capacity.The secrecy capacity highly depends on the system parameters such as the average signal energy,diffusion coefficientand reception duration. Moreover, the distance between the transmitter and the eavesdropper is also an important aspect of secrecy per- formance. For both amplitude and energy detection schemes secure distance is proposed as a secret metricover which the eavesdropper is incapable of signal recovery. Despite the case with CSK,the results of the secure metrics vary with the modulation type(e.g.pulse position,spacetype) and reception mechanism(e.g.passive,partially absorbingper fectly absorbing).For ease of understanding,Figure 3 depicts the modulation types and the corresponding CIRs with different reception mechanisms. Novel signa processing techniques and the biochemical channel properties can further assist the secrecy enhancement in the MC system.The molecular beam forming that avoids information disclosure can be realized via the flow generated in the channel.Besidesnew dimensions of diversity, such as the aforementioned molecular diversity of ionic compounds, can beexploited. Note that the feasibility of these methods can be validated by the derived secrecy metrics.
06-13
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

渴鱼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值