1044 火星数字 (20 分)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

AC代码:

#include<bits/stdc++.h>
using namespace std;
int n;
string s;
string low[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
string high[12]={"tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
int idx(string x,string y[]){
    for(int i=0;i<13;i++)
        if(y[i]==x)
            return i;
    return -1;
}
int main(){
    scanf("%d\n",&n);//因为后面使用的是getline,如果不加\n,会把输完n后的那个回车当成一次数据输入,导致下面少一次循环
    while(n--){
        getline(cin,s);
        if(isdigit(s[0])){
            //printf("diqiushu\n");
            int temp=stoi(s);
            if(temp%13==0&&temp!=0)
                cout<<high[temp/13-1]<<endl;
            else if(temp>13)
               cout<<high[temp/13-1]<<" "<<low[temp%13]<<endl;
            else
                cout<<low[temp%13]<<endl;
        }
        else if(s.size()<5){
            //printf("huoxingyiwei\n");
            if(idx(s,low)!=-1)
                cout<<idx(s,low)<<endl;
            else
                cout<<(idx(s,high)+1)*13<<endl;
        }
        else{
            //printf("huoxingliangwei\n");
            string gao=s.substr(0,3);
            string di=s.substr(4);
            //cout<<gao<<"***"<<di<<endl;
            cout<<(idx(gao,high)+1)*13+idx(di,low)<<endl;
        }
    }
    return 0;
}

这个题不难,就是情况要考虑清楚,要考虑0,考虑是数字的时候如果能被13整除等。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值