1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

 

Sample Output:

3 3 3.6 2 6.0 1 1.6

AC代码(自己写的):

#include<bits/stdc++.h>
using namespace std;
#define maxn 2005
int main(){
    int n1,n2,countn=0,e;
    double c,pro[maxn],a[maxn],b[maxn];
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(pro,0,sizeof(pro));
    scanf("%d",&n1);
    for(int i=0;i<n1;i++){
        scanf("%d%lf",&e,&c);
        a[e]=c;
    }
    scanf("%d",&n2);
    for(int i=0;i<n2;i++){
        scanf("%d%lf",&e,&c);
        b[e]=c;
    }
    for(int i=0;i<maxn;i++){
        if(a[i]!=0){
            for(int j=0;j<maxn;j++)
                if(b[j]!=0)
                    pro[i+j]+=a[i]*b[j];
        }
    }
    for(int i=0;i<maxn;i++){
        if(pro[i]!=0)
            countn++;
    }

    printf("%d",countn);
    for(int i=maxn-1;i>=0;i--){
        if(pro[i]!=0)
            printf(" %d %.1f",i,pro[i]);
    }
    return 0;
}

AC代码(算法笔记);

#include<bits/stdc++.h>
#define maxn 2005
using namespace std;
struct poly{
    int exp;
    double cof;
}poly[1005];
double ans[2005];
int main(){
    int n,m,number=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d %lf",&poly[i].exp,&poly[i].cof);
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        int exp;
        double cof;
        scanf("%d %lf",&exp,&cof);
        for(int j=0;j<n;j++)
            ans[exp+poly[j].exp]+=(cof*poly[j].cof);
    }
    for(int i=0;i<maxn;i++)
        if(ans[i]!=0.0)
            number++;
    printf("%d",number);
    for(int i=maxn-1;i>=0;i--)
        if(ans[i]!=0.0)
            printf(" %d %.1f",i,ans[i]);
    return 0;
}

书上比自己写的好的地方:

1.注意!和多项式加法不一样,这个地方数组要开到2000!

2.依旧不用开两个数组,第二个数组输入的时候循环就行。

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值