1058 A+B in Hogwarts (20分)*很简单的题,但可能由于溢出不能AC

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

 

Sample Output:

14.1.28

部分AC代码(自己写的):

#include<bits/stdc++.h>
using namespace std;
int main(){
    int g,s,k,gg,ss,kk;
    scanf("%d.%d.%d %d.%d.%d",&g,&s,&k,&gg,&ss,&kk);
    int sum=(g+gg)*(29*17)+(s+ss)*29+(k+kk);
    printf("%d.%d.%d",sum/(29*17),sum%(29*17)/29,sum%29);
    return 0;
}

不知道哪儿错了。。???

AC代码(算法笔记):

#include<bits/stdc++.h>
using namespace std;
int main(){
    int a[3],b[3],c[3];
    scanf("%d.%d.%d %d.%d.%d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2]);
    int carry=0;//进位
    c[2]=(a[2]+b[2])%29;
    carry=(a[2]+b[2])/29;
    c[1]=(a[1]+b[1]+carry)%17;
    carry=(a[1]+b[1]+carry)/17;
    c[0]=(a[0]+b[0]+carry);
    printf("%d.%d.%d",c[0],c[1],c[2]);
    return 0;
}

如果把算法笔记中的c[2]的算法改成如下,那么就会和自己写的一样出测试点2的错。why?

    int sum=(a[0]+b[0])*(29*17)+(a[1]+b[1])*29+(a[2]+b[2]);
    c[2]=(sum)%29;

如果把自己写的那段代码全都改成long long,则AC。可能是因为中间计算过程中可能溢出。而且不能只改sum,上面定义的g,s,k,gg,ss,kk都要改。如下正确:

#include<bits/stdc++.h>
using namespace std;
int main(){
    long long int g,s,k,gg,ss,kk;
    scanf("%lld.%lld.%lld %lld.%lld.%lld",&g,&s,&k,&gg,&ss,&kk);
    long long  sum=(g+gg)*(29*17)+(s+ss)*29+(k+kk);
    printf("%lld.%lld.%lld",sum/(29*17),sum%(29*17)/29,sum%29);
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值