贪心+复杂模拟---1033 To Fill or Not to Fill (25 分)

1033 To Fill or Not to Fill (25 分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

AC代码(算法笔记):

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#pragma warning(disable:4996)
using namespace std;
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
const int maxn = 500 + 10;
const int INF = 0x7fffffff;
struct station {
	double price, dis;
};
bool cmp(station &x, station &y) {
	return x.dis != y.dis ? x.dis < y.dis : x.price < y.price;
}
int main() {
	int n;
	double cmax, d, davg;
	scanf("%lf%lf%lf%d", &cmax, &d, &davg, &n);
	vector<station> st(n + 1);
	for (int i = 0; i < n; i++)
		scanf("%lf%lf", &st[i].price, & st[i].dis);
	st[n].dis = d;
	st[n].price = 0;
	sort(st.begin(), st.end(), cmp);
	//for (int i = 0; i < n; i++)
	//	printf("%lf %lf\n", st[i].price, st[i].dis);
	if (st[0].dis != 0) {//一开始没有油的话直接结束
		printf("The maximum travel distance = 0.00\n");
		return 0;
	}
	int now = 0;//当前所处加油站的编号
	double ans = 0, nowtank = 0, MAX = cmax * davg;//总花费、当前油量、满油下的行驶距离
	while (now < n) {//每次循环选出下一个需要到达的加油站
		//选出从当前加油站加满油能到达的第一个油价低于当前油价的加油站
		//如果没有低于当前油价的加油站,则选择价格最低的哪个
		int k = -1;//最低油价的加油站编号
		double priceMin = INF;//最低油价
		for (int i = now + 1; i <= n && st[i].dis - st[now].dis <= MAX; i++) {
			if (st[i].price < priceMin) {
				priceMin = st[i].price;
				k = i;
				if (priceMin < st[now].price)//若找到比当前油价还低的加油站,直接退出循环
					break;
			}
		}
		if (k == -1)break;//满油状态下到不了任一个加油站
		double need = (st[k].dis - st[now].dis) / davg;//从now到k需要的油量
		if (priceMin < st[now].price) {//加油站k的油价低于当前加油站油价
			if (nowtank < need) {//当前油量不够到k的
				ans += (need - nowtank)*st[now].price;
				nowtank = 0;
			}
			else {
				nowtank -= need;
			}
		}
		else {//加油站k的油价高于当前油价
			ans += (cmax - nowtank)*st[now].price;
			nowtank = cmax - need;
		}
		now = k;
	}
	if (now == n)printf("%.2f\n", ans);
	else printf("The maximum travel distance = %.2f\n", st[now].dis + MAX);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值