PATA 1033 To Fill or Not to Fill

1033 To Fill or Not to Fill 

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

待解决,思考中 

这个题目我想了好几天,知道是使用贪心算法但是对于严谨性一直欠考虑。

以下是《算法笔记》AC代码:

 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 510;
const int INF = 1000000000;

struct station{
	double price,dis;//价格,与起点的距离 
}st[maxn];

bool cmp(station a, station b)
{
	return a.dis<b.dis;//从小到大排序 
}

int main()
{
	int n;
	double Cmax,D,Davg;
	scanf("%lf%lf%lf%d",&Cmax,&D,&Davg,&n);
	for(int i=0;i<n;i++)
	{
		scanf("%lf%lf",&st[i].price,&st[i].dis);
	}
	st[n].price = 0;//终点 
	st[n].dis = D;//终点距离 
	sort(st,st+n,cmp);//加油站从小到大排序 
	if(st[0].dis!=0)//第一个加油站不为0,无法前进 
	{
		printf("The maximum travel distance = 0.00\n");
	 } 
	 else{
	 	int now = 0;//当前所处的加油站编号
		 double ans =0, nowTank=0, MAX = Cmax*Davg;
		 while(now<n) {
		 	//每次循环选出下一个需要到达的加油站
			 int k=-1;
			 double priceMin=INF;
			 for(int i=now+1;i<=n&&st[i].dis-st[now].dis<=MAX;i++)
			 {
			 	if(st[i].price<priceMin)
			 	{
			 		priceMin = st[i].price;
			 		k = i;
			 		if(priceMin<st[now].price)
			 		{
			 			break;
					 }
				 }
			  } 
			  
		if(k == -1)	break;
		double need = (st[k].dis-st[now].dis)/Davg;
		if(priceMin < st[now].price)
		{
			if(nowTank<need)
			{
				ans+=(need-nowTank)*st[now].price;
				nowTank = 0;
			}
			else{
				nowTank -= need;
			}
		}
		else{
			ans+=(Cmax-nowTank)*st[now].price;
			nowTank = Cmax - need;
		}
		now= k;
		}
		if(now == n)
		{
			printf("%.2f\n",ans);
		}
		else{
			printf("The maximum travel distance = %.2f\n",st[now].dis+MAX);
		}
		} 
		return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

陈沧夜

打个赏,让我买瓶可乐喝呗~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值