统计难题(字典树)

Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 
 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 
 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 
 

Sample Input

    
    
banana band bee absolute acm ba b band abc
 

Sample Output

    
    
2 3 1 0

解题思路:

直接套用模板即可,建树时,用一个变量去记录前缀的次数。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int maxn = 26;
struct Trie
{
    int n;   // n记录前缀次数
    Trie *next[maxn];
};
Trie *root;

void init()
{
    root = (Trie *)malloc(sizeof(Trie));
    for(int i = 0; i < maxn; i++)
        root -> next[i] = NULL;
}

void insert(char *word)
{
    Trie *temp = root;
    while(*word != '\0')
    {
        if(temp -> next[*word - 'a'] == NULL)
        {
            Trie *cur = (Trie *)malloc(sizeof(Trie));
            cur -> n = 1;
            for(int i = 0; i < maxn; i++)
                cur -> next[i] = NULL;
            temp -> next[*word - 'a'] = cur;
        }
        else
            temp -> next[*word - 'a'] -> n++;  // 重复就加1
        temp = temp -> next[*word-'a'];
        word++;
    }
}

int search(char *word)
{
    Trie *temp = root;
    for(int i = 0; word[i] != '\0'; i++)
    {
        temp = temp -> next[word[i] - 'a'];
        if(temp == NULL)
           return 0;
    }
    return temp -> n;
}

int main()
{
    char word[15];
    init();
    while(gets(word) && word[0] != '\0')
        insert(word);
    while(scanf("%s", word) != EOF)
    {
        int ans = search(word);
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值