Mayor's posters(线段树 + 离散化)

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l  i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l  i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l  i, l  i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

解题思路:

难点在于离散化,数据过大,必须进行离散化,而且不能是普通的离散化。如果两个相邻海报没有紧挨着,则在离散化的时候必须给两个海报之间留有间隔。

打个比方:(1,10)(1,4)(5,10)这组数据,普通离散化后应该为(1,4)(1,2)(3,4),那么答案应该为2。

(1,10)(1,3)(6,10)这组数据普通离散化后应该也为(1,4)(1,2)(3,4),答案也为2,可显然这题答案应该为3。问题就出在未留有间隔。

解决方案就是判断是否紧挨,若没有紧挨,就在离散化的时候往数组里面加一个数。在这里我采用的是用结构体来进行离散化。

剩下的就是求海报出现的个数问题,对线段进行着色,后贴的海报着色会覆盖之前的海报,最后统计颜色的种数即可。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
const int maxn = 11111;
int x[maxn << 2], col[maxn << 4], ans, c[maxn << 2];
bool flag[maxn << 2];
struct san
{
    int a, pos;
}f[maxn << 2];
bool cmp(san v, san t)
{
    return v.a < t.a;
}
void PushDown(int rt)
{
    if(col[rt] != 0)
    {
        col[rt << 1] = col[rt << 1 | 1] = col[rt];
        col[rt] = 0;
    }
}
void update(int L, int R, int c, int l, int r, int rt)
{
    if(L <= l && R >= r)
    {
        col[rt] = c;
        return;
    }
    PushDown(rt);
    int m = (l + r) >> 1;
    if (L <= m) update(L , R , c , lson);
    if (m < R) update(L , R , c , rson);
}
void query(int l, int r, int rt)
{
    if(col[rt] != 0)
    {
        if(!flag[col[rt]])  // 用flag检测该颜色是否之前出现过
        {
            ans++;
            flag[col[rt]] = true;
        }
        return;
    }
    if(l == r)
        return;
    int m = (l + r) >> 1;
    query(lson);
    query(rson);
}
int main()
{
    int t, n, ll, rr;
    scanf("%d", &t);
    while(t--)
    {
       ans = 0;
       memset(col , 0, sizeof(col));
       memset(flag, false, sizeof(flag));
       scanf("%d", &n);
       int k = 0;
       for(int i = 1; i <= n; i++)
       {
           scanf("%d%d", &ll, &rr); // 用f存储左右范围的值,因此有2*n个
           f[++k].a = ll;
           f[k].pos = k;
           f[++k].a = rr;
           f[k].pos = k;
       }
        sort(f + 1, f + k + 1, cmp); //进行第一次排序
        int t = 2 * n;
        for(int i = 2; i <= 2 * n; i++)
        {
            if(f[i].a > f[i - 1].a + 1)  //判断是否紧挨,无需考虑两者是否属于同一个海报
            {
                f[++t].a = f[i - 1].a + 1; // 未紧挨就加上一个紧挨的数
                f[t].pos = 0;  // 使其pos为0,就不会在离散化时进入有效值中
            }
        }
        int m = 1;
        c[1] = 1;
        sort(f + 1, f + t + 1, cmp); // 二次排序,产生间隔
        for(int i = 2; i <= t; i++)  // 去重处理
        {
            if(f[i].a == f[i - 1]. a)
                c[i] = m;
            else
                c[i] = ++m;
        }
        for(int i = 1; i <= t; i++)  // 得到有效值
            x[f[i].pos] = c[i];
        for(int i = 1; i <= 2 * n - 1; i += 2)  //进行着色
            update(x[i], x[i + 1], i, 1, 4 * n, 1);
        query(1, 4 * n, 1);  // 求颜色种类
        printf("%d\n", ans);
    }
    return 0;
}



评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值