HDU 4727 he Number Off of FFF

he Number Off of FFF

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3740    Accepted Submission(s): 1242


Problem Description
X soldiers from the famous " *FFF* army" is standing in a line, from left to right.
You, as the captain of  *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input
The rst line has a number T (T <= 10) , indicating the number of test cases.
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5)
It guaranteed that there is exactly one soldier who has made the mistake.
 

Output
For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input
  
  
2 3 1 2 4 3 1001 1002 1004
 

Sample Output
  
  
Case #1: 3 Case #2: 3
 

Source
//只要找出序列中与钱一个人的数字差不是1的人即可,要注意的是这些人是从一个队列中间截取下来的,所以很有可能第一个人就报错了
#include <iostream>

using namespace std;
const int maxn = 100005;
int vis[maxn];

int main()
{
    int t;
    cin>>t;
    int num = 0;
    while(t--)
    {
        cout<<"Case #"<<++num<<": ";
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>vis[i];
        }
        int flag = 0;
        for(int i=1;i<n;i++)
        {
            if(vis[i] - vis[i-1] != 1)
                flag = i+1;;
        }
        if(!flag)
        {
            flag = 1;
            cout<<flag<<endl;
        }
        else cout<<flag<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值