HDU 1251 统计难题(字典树模板)

34 篇文章 0 订阅
13 篇文章 0 订阅

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 38305    Accepted Submission(s): 14058


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
      
      
banana band bee absolute acm ba b band abc
 

Sample Output
      
      
2 3 1 0
 

Author
Ignatius.L
//字典树模板
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>

using namespace std;
const int maxn = 26;
struct Trie
{
    int cnt;//cnt表示一个字典树到此有多少相同前缀的数目
    struct Trie *next[maxn];//next是表示每层有多少种类的数
};
Trie *root;

void Trie_insert(char *str)
{
    Trie *p,*q = root;
    int len = strlen(str);
    for(int i=0;i<len;i++)
    {
        int ID = str[i] - 'a';
        if(q -> next[ID] == NULL)
        {
            p = new Trie;
            for(int j=0;j<maxn;j++)
            {
                p ->next[j] = NULL;
            }
            p -> cnt = 0;
            q -> next[ID] = p;
        }
        q = q -> next[ID];
        q -> cnt++;
    }
}
int Trie_search(char *str)
{
   Trie *p = root;
   int _count;
   int len = strlen(str);
   for(int i=0;i<len;i++)
   {
       int id = str[i] - 'a';
       if(p -> next[id] == NULL)
       {
           return 0;
       }
       else
       {
           p = p ->next[id];
           _count = p -> cnt;
       }
   }
   return _count;
}

int main()
{
    char str[15];
    root = new Trie;
    for(int i=0;i<maxn;i++)
    {
        root -> next[i] = NULL;
        root -> cnt = 0;
    }

    while(gets(str)&&str[0])
        Trie_insert(str);
    while(cin>>str)
        cout<<Trie_search(str)<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值