Problem B: 一切皆对象

Problem B: 一切皆对象

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 1487   Solved: 951
[ Submit][ Status][ Web Board]

Description

一切都是对象 —— Everything is an object。 所以,现在定义一个类Thing,来描述世界上所有有名字的事物。该类只有构造函数、拷贝构造函数和析构函数,并具有一个字符串数据成员来存储其名字。

Input

输入只有1行,是一个没有空白符的字符串。

Output

见样例。

Sample Input

NAME

Sample Output

A thing without name is created!A thing without name is copied!A thing named by NAME is created!A thing named by NAME is copied!A thing named by NAME is erased!A thing named by NAME is erased!A thing without name is erased!A thing without name is erased!

HINT

Append Code

#include <iostream>
#include <string>

using namespace std;

class Thing
{
public:
    string name;
    Thing():name("without name"){cout<<"A thing without name is created!"<<endl;}
    Thing(string name):name(name){cout<<"A thing named by "<<name<<" is created!"<<endl;}
    Thing(const Thing &t)
    {name = t.name;
    if(name == "without name")
    cout<<"A thing "<<name<<" is copied!"<<endl;
   else  cout<<"A thing named by "<<name<<" is copied!"<<endl;}
    ~Thing(){if(name == "without name") cout<<"A thing "<<name<<" is erased!"<<endl; else cout<<"A thing named by "<<name<<" is erased!"<<endl; }
};
int main()
{
    string name;
    Thing Thing1, Thing2(Thing1);
    cin>>name;
    Thing Thing3(name);
    Thing Thing4(Thing3);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值