Problem A: 一切皆对象 (C++期末)

Problem B: 一切皆对象

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 685   Solved: 350
[ Submit][ Status][ Web Board]

Description

一切都是对象 —— Everything is an object。 所以,现在定义一个类Thing,来描述世界上所有有名字的事物。该类只有构造函数、拷贝构造函数和析构函数,并具有一个字符串数据成员来存储其名字。

Input

输入只有1行,是一个没有空白符的字符串。

Output

见样例。

Sample Input

NAME

Sample Output

A thing without name is created!
A thing without name is copied!
A thing named by NAME is created!
A thing named by NAME is copied!
A thing named by NAME is erased!
A thing named by NAME is erased!
A thing without name is erased!
A thing without name is erased!

HINT

Append Code

append.cc, 、
int main() 
{ 
    string name; 
    Thing Thing1, Thing2(Thing1); 
    cin>>name; 
    Thing Thing3(name); 
    Thing Thing4(Thing3); 
    return 0; 
}

代码如下:
#include <iostream> 
#include <iomanip> 
#include <string> 
#include<cstring> 
using namespace std; 
class Thing 
{ 
private: 
    string name; 
public: 
    Thing() 
    { 
        name = "without name"; 
        cout<<"A thing without name is created!"<<endl; 
    } 
    Thing(string _name) 
    { 
        name = _name; 
        cout<<"A thing named by "<<name<<" is created!"<<endl; 
  
    } 
    Thing(Thing &t) 
    { 
        name=t.name; 
        if(name=="without name") 
          cout<<"A thing "<<name<<" is copied!"<<endl; 
        else
             cout<<"A thing named by "<<name<<" is copied!"<<endl; 
    } 
    ~Thing() 
    { 
        if(name=="without name") 
          cout<<"A thing "<<name<<" is erased!"<<endl; 
        else
            cout<<"A thing named by "<<name<<" is erased!"<<endl; 
    } 
}; 
int main() 
{ 
    string name; 
    Thing Thing1, Thing2(Thing1); 
    cin>>name; 
    Thing Thing3(name); 
    Thing Thing4(Thing3); 
    return 0; 
} 


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值