poj 2594 Treasure Exploration最小路径覆盖+传递闭包

Time Limit: 6000MS
Memory Limit: 65536K  
Total Submissions: 5587
Accepted: 2208  

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

Source



分析:一看就是最小路径覆盖,果断求最大匹配。。。。

         然后。。。。。。。

        贡献了一个WA。。。。。

       思考良久,参考大牛博客,发现原来这题有所不同。。。

       下面copy下大牛思路:

        这道题的一个亮点就是允许不同的路径经过同一个点,而最小路径覆盖的结论是在不同路径不经过同一个点的情况下给出的,所以这道题不能够直接套用结论.
在使用匈牙利算法之前要对整个图进行处理,把直接连通图变成是间接连通图,就是说如果由A经过一定的路径可以到达B,就令g[A][B]= 1.
这么做的目的就是,使得不同的路径可以通过相同的顶点,
比如线路1:a->b->c->d,线路2:f->g->b->k;
如果先选择了线路1,那么在选择线路2时,到线路到达g点后,检测到点b已经被占用,所以b点已经不可达,但是这时可以直接到达k点,因为经过处理后认为g和k是连通的.这么一来在点b被占用的情况下,我们依然可以到达原来通过点b才能到达的点,相当于通过了点b.

       于是自己yy写下以下代码。。:
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;
int const nMax = 600;

int my[nMax],map[nMax][nMax],vis[nMax];
int n,m;

void floyd(){
    for(int k=1;k<=n;k++){
        for(int i=1;i<=n;i++)if(i!=k){
            for(int j=1;j<=n;j++)if(j!=i&&j!=k){
                if(map[i][k]&&map[k][j])map[i][j]=true;
            }
        }
    }
    return ;
}

bool find(int u){
    for(int v=1;v<=m;v++)if(map[u][v]&&!vis[v]){
        vis[v]=1;
        if( my[v]==-1 || find(my[v]) ){
            my[v]=u;
            return true;
        }
    }
    return false;
}

int MaxMatch(){
    int ans=0;
    memset(my,-1,sizeof(my));
    for(int u=1;u<=n;u++){
        memset(vis,0,sizeof(vis));
        if(find(u))ans++;
    }
    return ans;
}

int MinCover(){
    return n-MaxMatch();
}

int u,v;
int main()
{
    while(~scanf("%d%d",&n,&m),n||m){
        for(int i=1;i<=n;i++)for(int j=1;j<=n;j++)map[i][j]=0;
        for(int i=0;i<m;i++){
            scanf("%d%d",&u,&v);
            map[u][v]=1;
        }
        m=n;
        floyd();
        int ans=MinCover();
        printf("%d\n",ans);
    }
    return 0;
}

    终于AC了!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值