1015 Reversible Primes (20 分) Java

1015 Reversible Primes (20 分) Java

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目大意:如果一个数本身是素数,在给定进制下反转后的数在十进制下还是素数,那么这个数就是可逆素数。要求判断一个数是否为可逆素数。

解题思路:先写一个函数判断是否为素数,如果这个数是素数,那么将其转换反转,用数值a[]存储n在radix下的每一位数,按顺序存储,实际就完成反转,然后转换为10进制数。

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner in=new Scanner(System.in);
        int n=0;
        int radix;
        while(n>=0){
            n=in.nextInt();
            radix=in.nextInt();
          if(isPrime(n)==false){
              System.out.println("No");
          }else {
              int a[]=new int[100];
              int i=0;
              int value=0;
              while (n!=0){
                  a[i++]=n%radix;
                  n=n/radix;
              }
              for(int j=0;j<i;j++){
                  value=value*radix+a[j];
              }
              if(isPrime(value)==true){
                  System.out.println("Yes");
              }else{
                  System.out.println("No");
              }
          }
        }

    }
    public static boolean isPrime(int n) {
        if (n==0 || n==1) return false;
        for (int i=2;i<=Math.sqrt(n);i++) {
            if (n%i == 0)
                return false;
        }
        return true;
    }


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值