GYM 101550 D.Daydreaming Stockbroker(贪心)

142 篇文章 0 订阅

Description

初始有 100 100 元,给出 n n 天的股票价格ai,每天可以买整数股,也可以把手里的股票卖出整数股,但是一天可以买或卖的股票总数不超过 105 10 5 股,问 n n 天后最多有多少钱

Input

第一行输入一整数n表示天数,之后输入 n n 个整数a1,...,an表示这 n n 天的股票价格(1n365,1ai500)

Output

输出 n n 天后最多的钱数,保证答案不超过232

Sample Input

6
100
200
100
150
125
300

Sample Output

650

Solution

贪心,把序列分成若干连续的不减段,对每一段,在最小值处买,在最大值处卖

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=1001;
int n,a[maxn];
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        ll sum=100;
        for(int i=1;i<n;i++)
        {
            int j=i+1;
            while(j<=n&&a[j]>=a[j-1])j++;
            j--;
            if(j==i)continue;
            ll num=min(100000ll,sum/a[i]);
            sum+=num*(a[j]-a[i]);
            i=j;
        }
        printf("%lld\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值