PAT-甲级-1110 Complete Binary Tree (25 分)

60 篇文章 0 订阅

1110 Complete Binary Tree (25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题目大意:给定一棵二叉树,判断该二叉树是否为完全二叉树。

解题思路:

  • 根结点没有给定,需要用vector标记所有孩子结点,没有出现的结点即为根结点;
  • 判断是否是完全二叉树,用广度优先搜索bfs:
    • 访问的当前结点不是叶子节点时,计数num++,保存当前访问的结点;
    • 访问出现第一个叶子节点时,判断计数num==n成立?YES:NO。
#include <iostream>
#include <string>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
struct node{
    int l,r;
};
int main(){
    std::ios::sync_with_stdio(false);
    int n,l,r,root=0;
    cin>>n;
    vector<node> v(n);
    vector<int> cnt(n);
    string a,b;
    rep(i,0,n){
        cin>>a>>b;
        l = a=="-"?-1:stoi(a);
        r = b=="-"?-1:stoi(b);
        if(l!=-1)
            cnt[l] = 1;
        if(r!=-1)
            cnt[r] = 1;
        node no = {l,r};
        v[i] = no;
    }
    while(cnt[root]!=0) root++;
    queue<int> q;
    q.push(root);
    int num=0,last=0;
    while(!q.empty()){
        int now = q.front();
        q.pop();
        if(now!=-1){
            last = now;
            num++;
        }else{
            if(num==n)
                printf("YES %d",last);
            else
                printf("NO %d",root);
            return 0;
        }
        q.push(v[now].l);
        q.push(v[now].r);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值