PAT-甲级-1020 Tree Traversals (25 分)

60 篇文章 0 订阅

1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意:已知后序和先序,输出二叉树的层序;

解题思路:

  • 已知后序+中序→深搜dfs遍历二叉树的模板:
    • 左子树:dfs(posU - inR + i - 1 , inL , i-1);
    • 右子树:dfs(posU - 1 , i+1 , inR);
       
#include <iostream>
#include <vector>
#define rep(i,j,k)    for(int i=j;i<k;i++)
using namespace std;
vector<int> in,pos,level(10000,-1);
void dfs(int u,int l,int r,int index){
    if(l >r)    return;
    int i=l;
    while(i<r && in[i] != pos[u])    i++;
    level[index] = pos[u];
    dfs(u-r+i-1,l,i-1,2*index);
    dfs(u-1,i+1,r,2*index+1);
}
int main(){
    std::ios::sync_with_stdio(false);
    int n;
    cin>>n;
    in.resize(n);
    pos.resize(n);
    rep(i,0,n)  cin>>pos[i];
    rep(i,0,n)  cin>>in[i];
    dfs(n-1,0,n-1,1);
    int cnt=0;
    rep(i,1,level.size()){
        int d=level[i];
        if(d!=-1){
            printf("%d",d);
            cnt++;
            if(cnt!=n)    printf(" ");
        }
        
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值