【PAT甲级 - C++题解】1020 Tree Traversals

本文详细介绍了如何利用二叉树的后序与中序遍历序列来构建原二叉树,并实现层次遍历。通过哈希映射存储中序遍历的节点位置,然后递归构建二叉树结构,最后使用广度优先搜索输出层次遍历序列。代码示例采用C++实现。
摘要由CSDN通过智能技术生成

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1020 Tree Traversals (pintia.cn)
🔑中文翻译:树的遍历
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2
题意

第一行包含整数 N N N,表示二叉树的节点数。

第二行包含 N N N 个整数,表示二叉树的后序遍历。

第三行包含 N N N 个整数,表示二叉树的中序遍历。

输出一行 N N N 个整数,表示二叉树的层序遍历。

思路
  1. 由于题目给定每个结点的值都不同,所以可以用哈希表存储每个结点在中序数组中的下标,方便后续使用。

  2. 通过下标构建二叉树(其中 k-1-il 表示左子树结点个数):

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-b90sAL9i-1664017415354)(PAT 甲级辅导.assets/3.png)]

  3. 通过 bfs 进行层次遍历,并输出最终结果。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 40;
int n;
int posorder[N], inorder[N];
unordered_map<int, int> l, r, pos;
int q[N];

//构建树
int build(int il, int ir, int pl, int pr)
{
    int root = posorder[pr];  //获得根结点
    int k = pos[root];    //获得该结点在中序数组中的下标
    if (il < k)   l[root] = build(il, k - 1, pl, pl + (k - 1 - il));        //递归左子树
    if (k < ir)   r[root] = build(k + 1, ir, pl + (k - 1 - il) + 1, pr - 1);    //递归右子树
    return root;
}

//层次遍历
void bfs(int root)
{
    //初始化,用队列来模拟层次遍历
    int hh = 0, tt = 0;
    q[0] = root;

    //开始遍历
    while (hh <= tt)
    {
        int k = q[hh++];
        if (l.count(k))  q[++tt] = l[k];
        if (r.count(k))  q[++tt] = r[k];
    }

    //输出结果
    cout << q[0];
    for (int i = 1; i < n; i++)    cout << " " << q[i];
    cout << endl;
}

int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> posorder[i];
    for (int i = 0; i < n; i++)
    {
        cin >> inorder[i];
        pos[inorder[i]] = i;  //记录该值在中序数组中的下标
    }

    int root = build(0, n - 1, 0, n - 1);

    bfs(root);

    return 0;
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值