使用gradle打包apk遇到的问题

ant和meave都玩过了,最近没什么事,来试试用gradle打包android应用,和以往一样,难免会遇到各种问题,记录下来,以免以后忘记


第一个


* What went wrong:
A problem occurred evaluating root project 'FurTest'.
> Failed to apply plugin [id 'android']
   > Gradle version 1.10 is required. Current version is 2.2.1. If using the gra
dle wrapper, try editing the distributionUrl in D:\real_workspace\FurTest\gradle
\wrapper\gradle-wrapper.properties to gradle-1.10-all.zip


FurTest是我的项目名


看问题提示是需要1.10版的gradle,而我安装的是最新的2.2.1版,需要在xxx/xxx目录下新建指定文件


但其实只要

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:0.14+'
    }
}


把 classpath 'com.android.tools.build:gradle:改成0.14就好了(我也不知道为什么。。。)


* What went wrong:
Execution failed for task ':preBuild'.
> failed to find Build Tools revision 19.0.0


问题原因:没有19.0.0版的build tools

解决方法:打开sdkmanager.exe,在tools下找到rev对应为19的build tools,安装下就好了


* What went wrong:
Execution failed for task ':preBuild'.
> The SDK Build Tools revision (19.0.0) is too low for project 'FurTest'. Minimu
m required is 19.1.0


解决方法:把buildToolsVersion从19改成19.1.0,然后再sdkmanager里下载19.1.0的build tools





微信扫码订阅
UP更新不错过~
关注
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

veardn

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值