PAT A1043. Is It a Binary Search Tree (25) [⼆叉查找树BST]

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The lef subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the lef and right subtrees must also be binary search trees.
If we swap the lef and right subtrees of every node, then the resulting tree is called the Mirror Image of a
BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a
BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000).
Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or
the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder
traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be
no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
题⽬⼤意:给定⼀个整数键值序列,现请你编写程序,判断这是否是对⼀棵⼆叉搜索树或其镜像进⾏
前序遍历的结果。
分析:假设它是⼆叉搜索树,⼀开始isMirror为FALSE,根据⼆叉搜索树的性质将已知的前序转换为后
序,转换过程中,如果发现最后输出的后序数组⻓度不为n,那就设isMirror为true,然后清空后序数
组,重新再转换⼀次(根据镜⾯⼆叉搜索树的性质),如果依旧转换后数组⼤⼩不等于n,就输出no
否则输出yes


#include <cstdio>
#include <vector>
using namespace std;
bool isMirror;    //是否镜像 
vector<int> pre, post; //先序 后序 
void getpost(int root, int tail) {
	if(root > tail) return ;
	int i = root + 1, j = tail;
	if(!isMirror) {
		while(i <= tail && pre[root] > pre[i]) i++;	
		while(j > root && pre[root] <= pre[j]) j--;
	} else {
		while(i <= tail && pre[root] <= pre[i]) i++;
		while(j > root && pre[root] > pre[j]) j--;
	}
	if(i - j != 1) return ;
	getpost(root + 1, j);
	getpost(i, tail);
	post.push_back(pre[root]);
}
int main() {
	int n;
	scanf("%d", &n);
	pre.resize(n);
	for(int i = 0; i < n; i++)
		scanf("%d", &pre[i]);
	getpost(0, n - 1);
	if(post.size() != n) {
		isMirror = true;
		post.clear();
		getpost(0, n - 1);
	}
	if(post.size() == n) {
		printf("YES\n%d", post[0]);
		for(int i = 1; i < n; i++)
			printf(" %d", post[i]);
	} else {
		printf("NO");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值