PAT A1086. Tree Traversals Again (25) [树的遍历]

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:
3 4 2 6 5 1
题⽬⼤意:⽤栈的形式给出⼀棵⼆叉树的建⽴的顺序,求这棵⼆叉树的后序遍历
分析:栈实现的是⼆叉树的中序遍历(左根右),⽽每次push⼊值的顺序是⼆叉树的前序遍历(根左
右),所以该题可以⽤⼆叉树前序和中序转后序的⽅法做.
root为当前⼦树的根结点在前序pre中的下标, start和end为当前⼦树的最左边和最右边的结点在中序in
中的下标。⽤i找到当前⼦树的根结点root在中序中的下标,然后左边和右边就分别为当前根结点root
的左⼦树和右⼦树。递归实现

#include<cstdio>
#include<iostream>
#include<vector>
#include<stack>
#include<cstring>
using namespace std;

vector<int> pre, in, post, value;

void postorder(int root,int start,int end){
	if(start>end)return;
	int i = start;
	while(i<end&&in[i]!=pre[root])i++;
	postorder(root+1,start,i-1);
	postorder(root+1+i-start,i+1,end);
	post.push_back(pre[root]);
}

int main(){
	int n;
	cin>>n;
	string str;
	stack<int> s;
	int key = 0,cnt = 0;
	while(cnt!=n){
		cin>>str;
		if(str.length()==4){
			int num;
			cin>>num;
			value.push_back(num);
			pre.push_back(key);
			s.push(key++);
		}else{
			in.push_back(s.top());
			s.pop();
			cnt++;
		}
	}
	postorder(0,0,n-1);
	cout<<value[post[0]];
	for(int i = 1;i<n;i++)
		cout<<" "<<value[post[i]];
		return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值