PTA 06-图2 Saving James Bond - Easy Version

PTA 06-图2 Saving James Bond - Easy Version

原题链接

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
结尾无空行
Sample Output 1:
Yes
结尾无空行
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No

思路

(1)数据结构
陈越姥姥说的图不一定要用邻接表和邻接矩阵来做->结构体存储坐标信息
(2)特判
当主角在岛上的时候,他能在岛边缘跳->他挑的范围多了岛的半径那么长
(3)程序出口
这题的程序出口是判断下一跳是否超过100,100的正方形的坐标边界,非常巧妙
(4)递归的主体
DFS递归的主体不再是“邻接的结点”,而是遍历1-N,如果距离在可跳范围内,就是“邻接的结点”

注意:不要忘记存的是1-N,0是岛。本人因为这个边界问题卡了一会

for(int i=1;i<=N;i++);

Code

#include <iostream>
#include<cmath>
#define radius 7.5
#define MaxSize 101
using namespace std;
int N,D;//N个鳄鱼,Jons Bound能跳的最远距离
struct croNode{
    int x;
    int y;
}Cro[MaxSize];
bool visited[MaxSize]={false};//DFS中用于判断的visited数组
bool result=false;//最后的结果
//判断是否能跳达
bool Distance(int v1,int v2){
    double Maxdis=D;
    if(v1==0){//起点在孤岛时的特判
        Maxdis=D+radius;
    }
    double dis=sqrt(pow(Cro[v1].x-Cro[v2].x,2)+pow(Cro[v1].y-Cro[v2].y,2));
    bool res=dis>Maxdis?false:true;
    return res;
}
//判断该结点是不是可以逃脱,直接跳到岸边
bool CanEscape(int v){
    double Maxdis=D;
    if(v==0){//起点在孤岛时的特判
        Maxdis=D+radius;
    }
    if(Cro[v].x+Maxdis>=50||Cro[v].x-Maxdis<=-50||Cro[v].y+Maxdis>=50||Cro[v].y-Maxdis<=-50){
        return true;
    }else{
        return false;
    }
}
//DFS递归调用
int DFS(int v){
    visited[v]=true;
    if(CanEscape(v)){
        result=true;
    }else{
        for(int i=1;i<=N;i++){
            if(!visited[i]&&Distance(v,i)){//找下一个没有被访问过而且能跳到的结点
                 result=DFS(i);
            }
        }
    }
    return result;
}
int main(){
    scanf("%d %d",&N,&D);
    //孤岛
    Cro[0].x=0;
    Cro[0].y=0;
    for(int i=1;i<=N;i++){
        scanf("%d %d",&Cro[i].x,&Cro[i].y);
    }
    visited[0]=true;
    for(int i=1;i<=N;i++){
        if(Distance(0,i)){//能够从0到达i
            result=DFS(i);
            if(result==true){
                printf("Yes");break;
            }
        }
    }
    if(result==false){
        printf("No");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值