HDU - 1856 - More is better

HDU - 1856 - More is better

Time Limit: 5000/1000 MS (Java/Others)     Memory Limit: 327680/102400 K (Java/Others)

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


题意:一共有10000000人,给你一个数n,下面n行a, b好,代表 a 和 b 是好朋友,问好朋友的最大集合有多大

再合并集合的时候,有启发式合并,根据两棵数的秩来决定怎么合并,在写un的时候稍微改编一下就OK了,这里的秩不再代表树高,而是代表集合里的人数


#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 10000005
using namespace std;

int u[MAXN], rnk[MAXN];
int ans;

int find(int x){
    if(x != u[x])
        u[x] = find(u[x]);
    return u[x];
}

void un(int a, int b){
    a = find(a);
    b = find(b);
    if(a == b)
        return;
    if(rnk[a] > rnk[b]){
        u[b] = a;
        rnk[a]+=rnk[b];        //这里的秩代表集合里的人数
        if(ans < rnk[a])
            ans = rnk[a];
    }
    else{
        u[a] = b;
        rnk[b]+=rnk[a];
        if(ans < rnk[b])
            ans = rnk[b];
    }
}

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF){
        if(!n){                     //当n=0时输出1,注意题目n的范围 
            printf("1\n");
            continue;
        }

        for(int i = 0; i < MAXN; i++){
            u[i] = i;
            rnk[i] = 1;
        }


        ans = 0;
        while(n--){
            int a, b;
            scanf("%d %d", &a, &b);
            un(a, b);
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值