Matrix Power Series

Matrix Power Series
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 16743 Accepted: 7135

Description

Given a n × n matrix A and a positive integer k, find the sum S = A + A2 + A3 + … + Ak.

Input

The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.

Output

Output the elements of S modulo m in the same way as A is given.

Sample Input

2 2 4
0 1
1 1

Sample Output

1 2
2 3

Source

POJ Monthly--2007.06.03, Huang, Jinsong




#include <cstdio>
#include <math.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
using namespace std;


struct matt
{
    int m[75][75];
} ;




matt f,s,unitmatt;


int n,m;
int k;


matt mul(matt a,matt b)  //矩阵相乘
{
int i,j,k;
matt c;

for (i=1;i<=2*n;i++)
{
for (j=1;j<=2*n;j++)
{
c.m[i][j] = 0;
for (k=1;k<=2*n;k++)
{
c.m[i][j]+=a.m[i][k]* b.m[k][j];
c.m[i][j]%=m;
}
}
}
return c;
}


matt pow_m(matt a,int kk)   //矩阵快速幂
{

matt res = unitmatt;
while(kk)
{
if (kk&1)
{
res=mul(res,a);
}

a=mul(a,a);
kk=kk>>1;
}


return res;



}




int main()
{  
int i,j;
scanf("%d%d%d",&n,&k,&m);
               //
for (i=1;i<=n*2;i++)
{
unitmatt.m[i][i]=1;
}
 
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
scanf("%d",&f.m[i][j]);
}



for(i=1;i<=n;i++)

f.m[i][i+n]=1;
f.m[i+n][i+n]=1;
}
  //构造B= |A E | 矩阵
                                                      |0 E |
s=pow_m(f,k+1);



for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(i!=j)
printf("%d ",s.m[i][j+n ]);        //输出矩阵的右上子矩阵,注意减E。
else
{
if (s.m[i][j+n]==0)
printf("3 ");
else 
printf("%d ",s.m[i][j+n]-1);
}
} printf("\n");
}






return 0;


这样构造矩阵的方法很巧妙,还可以用在例如求斐波那契数列等地方

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值