PAT甲级A1007 Maximum Subsequence Sum (25)

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意:给定数组,输出其最大连续子列和,并输出该最大连续子列的第一个元素和最后一个元素(注意不是下标),如果所有元素都是负数,则定义其最大连续子列和为0,输出零之后,再输出整个数组的第一个元素和最后一个元素。

思路:

1.动态规划问题,设置数组dp[]存储最大连续子列和,则有状态转移方程dp[i]=max(dp[i-1]+data[i],data[i])。

2.设置变量mx存储最大的子列和,并用mxL(初始为0)标记该最大子列的左边界,mxR(初始为0)标记右边界,每次变更mx时更新右边界mxR=i,仅当dp[i-1]+data[i]<data[i]时更新左边界为mxL=i。

3.最大子列和mx初始化为-1(不能直接初始化为0,因为最大和mx为0时需要特殊判断输出,整个数列的第一个和最后一个元素)。

参考代码:

#include<cstdio>
using namespace std;
const int maxn=10010;
int data[maxn],dp[maxn]={0};
int main()
{
	int k,mx=-1,mxL=0,mxR=0,temp=0;
	scanf("%d",&k);
	for(int i=0;i<k;i++)
	{
		scanf("%d",&data[i]);
		if(i==0) dp[i]=data[i];
		else if(dp[i-1]+data[i]>data[i]){
			dp[i]=dp[i-1]+data[i];
		}else{
			dp[i]=data[i];
			temp=i;
		}
		if(dp[i]>mx){
			mx=dp[i];
			mxL=temp;
			mxR=i;
		}
	}
	if(mx==-1) printf("0 %d %d\n",data[0],data[k-1]);
	else printf("%d %d %d\n",mx,data[mxL],data[mxR]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值